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1. What is HFSS v 9.0? 
HFSS is a high-performance full-wave electromagnetic (EM) field simulator 
for arbitrary 3D volumetric passive device modeling that takes advantage of 
the familiar Microsoft Windows graphical user interface. It integrates 
simulation, visualization, solid modeling, and automation in an easy-to-learn 
environment where solutions to your 3D EM problems are quickly and 
accurately obtained. Ansoft HFSS employs the Finite Element Method (FEM), 
adaptive meshing, and brilliant graphics to give you unparalleled performance 
and insight to all of your 3D EM problems. Ansoft HFSS can be used to 
calculate parameters such as S Parameters, Resonant Frequency, and 
Fields. 

 
2. HFSS USES 

Typical uses include: 
 

• Package Modeling 
BGA, QFP, Flip-Chip. 

• PCB Board Modeling 
Power/Ground planes, Mesh Grid Grounds, Backplanes. 

• Silicon/GaAs 
Spiral Inductors, Transformers. 

• EMC/EMI 
Shield Enclosures, Coupling, Near- or Far-Field Radiation 

• Antennas/Mobile Communications 
      Patches, Dipoles, Horns, Conformal Cell Phone Antennas, 
Quadrafilar Helix, Specific Absorption Rate(SAR), Infinite Arrays, 
Radar Cross Section(RCS), Frequency Selective Surfaces(FSS). 

• Connectors 
Coax, SFP/XFP, Backplane, Transitions. 

• Waveguide 
Filters, Resonators, Transitions, Couplers. 

• Filters 
Cavity Filters, Microstrip, Dielectric. 

 
HFSS is an interactive simulation system whose basic mesh element is a 
tetrahedron. This allows you to solve any arbitrary 3D geometry, especially 
those with complex curves and shapes, in a fraction of the time it would take 
using other techniques. 

 
The name HFSS stands for High Frequency Structure Simulator. Ansoft 
pioneered the use of the Finite Element Method (FEM) for EM simulation by 
developing/implementing technologies such as tangential vector finite 
elements, adaptive meshing, and Adaptive Lanczos-Pade Sweep (ALPS). 
Today, HFSS continues to lead the industry with innovations such as Modes-
to-Nodes and Full- Wave Spice™. 
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Ansoft HFSS has evolved over a period of years with input from many users 
and industries. In industry, Ansoft HFSS is the tool of choice for high-
productivity research, development, and virtual prototyping. 

 
 
3. Getting Help 

If you have any questions while you are using Ansoft HFSS v.9.0 you can find 
answers in several ways: 

 
Ansoft HFSS Online Help provides assistance while you are working. 

• To get help about a specific, active dialog box, click the Help button 
in the dialog box or press the F1 key. 

• Select the menu item Help > Contents to access the online help 
system. 

• Tooltips are available to provide information about tools on the 
toolbars or dialog boxes. When you hold the pointer over a tool for 
a brief time, a tooltip appears to display the name of the tool. 

• As you move the pointer over a tool or click a menu item, the Status 
Bar at the bottom of the Ansoft HFSS window provides a brief 
description of the function of the tool or menu item. 

• The Ansoft HFSS v.9.0 Getting Started guide provides detailed 
information about using HFSS to create and solve 3D EM projects. 

 
Ansoft Technical Support 

1. To contact Ansoft technical support staff in your geographical area, 
please log on to the Ansoft corporate website, www.ansoft.com and 
select Contact. 

o Your Ansoft sales engineer may also be contacted in order 
to obtain this information. 

 
 

4. Visiting the Ansoft Web Site 
If your computer is connected to the Internet, you can visit the Ansoft Web 
site to learn more about the Ansoft company and products. 

 
2. From the Ansoft Desktop 

o Select the menu item Help > Ansoft Corporate Website to 
access the Online Technical Support (OTS) system. 

 
3. From your Internet browser 

o Visit  www.ansoft.com  
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5. For Technical Support 
The following link will direct you to the Ansoft Support Page. The Ansoft 
Support Pages provide additional documentation, training, and application 
notes. 

 
• Web Site: http://www.ansoft.com/support.cfm  

 
 

6. Ansoft Terms 
The Ansoft HFSS window has several optional panels: 

 
i. Project Manager 

ii. Message Manager 
iii. Property Window 
iv. Progress Window 
v. 3D Modeler Window 

 
These above managers and windows are shown in Fig (1) and their details are 
given in coming sections. 
 

 
 
     Fig (1): Ansoft HFSS window. 
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6.1     Project Manager 
    A Project Manager which contains a design tree which lists the structure of 

the project is shown in Fig (2). 
 

 
         Fig (2): Ansoft HFSS Project Manager. 
 
6.2      Message Manager 

     A Message Manager that allows you to view any errors or warnings that 
occur before you begin a simulation is shown in Fig (3).  

 

 
 
    Fig (3): Ansoft HFSS Message Manager. 
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6.3      Property Window 
     A Property Window that displays and allows you to change model 

parameters or attributes is shown in Fig (4). 
 
 

 
 

    Fig (4): Ansoft HFSS Property Window. 
 
 
 
6.4      Progress Window 

     A Progress Window that displays solution progress is shown in Fig (5). 
 

 

 
 
 

Fig (5): Ansoft HFSS Progress Window. 
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6.5      3D Modeler Window 
     A 3D Modeler Window which contains the model and model tree for the 

active design is shown in Fig (6), model and model tree are shown in Fig (7) and 
Fig (8) respectively. 

 
Fig (6): Ansoft HFSS 3D Modeler Window. 

 
 

 
 

  Fig (7): Model. 
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Fig (8): 3D Modeler Design Tree. 
 
 

7. Design Windows 
In the Ansoft HFSS Desktop, each project can have multiple designs and 
each design is displayed in a separate window. You can have multiple 
projects and design windows open at the same time. Also, you can have 
multiple views of the same design visible at the same time. 

 
To arrange the windows, you can drag them by the title bar, and resize them 
by dragging a corner or border. Also, you can select one of the following 
menu options: Window >Cascade, Window >Tile Vertically, or Window > Tile 
Horizontally. 

 
To organize your Ansoft HFSS window, you can iconize open designs. Click 
the Iconize ** symbol in the upper right corner of the document border. An 
icon appears in the lower part of the Ansoft HFSS window. If the icon is not 
visible, it may be behind another open document. Resize any open 
documents as necessary. Select the menu item Window > Arrange Icons to 
arrange them at the bottom of the Ansoft HFSS window. Select the menu item 
Window > Close All to close all open design. You are prompted to Save 
unsaved designs. 
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Fig (9): Design Window. 

 
 
8. Toolbars 

The toolbar buttons are shortcuts for frequently used commands. Most of the 
available toolbars are displayed in this illustration of the Ansoft HFSS initial 
screen, but your Ansoft HFSS window probably will not be arranged this way. 
 
You can customize your toolbar display in a way that is convenient for you. 
Some toolbars are always displayed; other toolbars display automatically 
when you select a document of the related type. For example, when you 
select a 2D report from the project tree, the 2D report toolbar displays, as 
shown in Fig (9) 

 

 
 

Fig (9): Ansoft HFSS Toolbars. 
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8.1      To display or hide individual toolbars 
 

• Right-click the Ansoft HFSS window frame. 
o A list of all the toolbars is displayed. The toolbars with a check mark 

beside them are visible; the toolbars without a check mark are 
hidden. Click the toolbar name to turn its display on or off. 

 
• To make changes to the toolbars, select the menu item Tools > 

Customize. 
 
 

 
 

Fig (10): Ansoft HFSS Panels and Toolbars. 
 

8.2      Customize and Arrange Toolbars 
     To customize toolbars: 
 

• Select the menu item Tools > Customize, or right-click the Ansoft 
HFSS window frame and click Customize at the bottom of the toolbar 
list. 

• In the Customize dialog, you can do the following: 
 

o View a Description of the toolbar commands. 
i. Select an item from the Component pull-down list. 
ii. Select an item from the Category list. 
iii. Using the mouse click on the Buttons to display the 

Description. 
iv. Click the Close button when you are finished. 
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o Toggle the visibility of toolbars 
i. From the Toolbar list, toggle the check boxes to control the 

visibility of the toolbars. 
ii. Click the Close button when you are finished. 

 

 
Fig (11): Ansoft HFSS customize. 

 
9. Ansoft HFSS Desktop 

The Ansoft HFSS Desktop provides an intuitive, easy-to-use interface for 
developing passive RF device models. Creating designs, involves the 
following: 

 
i. Parametric Model Generation – creating the geometry, boundaries and 

excitations. 
ii. Analysis Setup – defining solution setup and frequency sweeps. 
iii. Results – creating 2D reports and field plots. 
iv. Solve Loop - the solution process is fully automated. 

 
To understand how these processes co-exist, examine the illustration shown 
In Fig(12). 
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Fig (12): Ansoft HFSS Desktop. 
 
 
10. Opening a HFSS project 

This section describes how to open a new or existing project. 
 

10.1 Opening a New project 
To open a new project: 

i. In an Ansoft HFSS window, select the menu item File > New. 
ii. Select the menu Project > Insert HFSS Design. 

 
10.2 Opening an Existing HFSS project 

To open an existing project: 
i. In an Ansoft HFSS window, select the menu File > Open. Use the Open 

dialog to select the project. 
ii. Click Open to open the project 
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Fig (13): Opening a HFSS  project. 
 
10.3 Opening an Existing Project from Explorer 

You can open a project directly from the Microsoft Windows Explorer. To 
open a project from Windows Explorer, do one of the following: 

 
i. Double-click on the name of the project in Windows Explorer. 
ii. Right-click the name of the project in Windows Explorer and select Open 

from the shortcut menu. 
 

11. Set Solution Type 
This section describes how to set the Solution Type. The Solution Type 

defines the type of results, how the excitations are defined, and the 
convergence. The following Solution Types are available: 

 
i. Driven Modal - calculates the modal-based S-parameters. The S-matrix 

solutions will be expressed in terms of the incident and reflected powers 
of waveguide modes. 

ii. Driven Terminal - calculates the terminal-based S-parameters of 
multiconductor transmission line ports. The S-matrix solutions will be 
expressed in terms of terminal voltages and currents. 

iii. Eignemode – calculate the eigenmodes, or resonances, of a structure. 
The Eigenmode solver finds the resonant frequencies of the structure 
and the fields at those resonant frequencies. 

 
11.1 Convergence 

i. Driven Modal – Delta S for modal S-Parameters. This was the only 
convergence method available for Driven Solutions in previous versions. 

ii. Driven Terminal New – Delta S for the single-ended or differential nodal 
S-Parameters. 

iii. Eigenmode - Delta F 
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11.2 To set the solution type: 
Select the menu item HFSS > Solution Type 
Solution Type Window: 

• Choose one of the following: 
o Driven Modal 
o Driven Terminal 
o Eigenmode 
o  

• Click the OK button 
 

Fig (14): Solution Type. 
 

12. Parametric Model Creation 
The Ansoft HFSS 3D Modeler is designed for ease of use and flexibility. 

The power of the 3D Modeler is in its unique ability to create fully parametric 
designs without editing complex macros/model history. 

 
The purpose of this section is to provide an overview of the 3D Modeling 
capabilities. By understanding the basic concepts outlined here you will be 
able to quickly take advantage of the full feature set offered by the 3D 
Parametric Modeler. 
 


